Install jailbreak g0blin for iOS 10.3.x | 64-bit | A7-A9 install with Cydia Impactor


‎ Install G0BLIN Jailbreak  

  Device Compatibility :


 You can jailbreak iOS 10.3.x using a new tool called G0blin. This tool supports all 64-bit devices. A7-A9 devices.
your ioS device
Before we proceed here are some important points to note:
  • G0blin jailbreak supports the following iOS 10 versions:
    • iOS 10.3.1, iOS 10.3.2, iOS 10.3.3
  • It supports the following 64-bit iOS 10.3.3 compatible iOS devices:
    • iPhone 6s, iPhone 6s Plus, iPhone 6, iPhone 6 Plus, iPhone SE, iPhone 5s
    • iPad Air 2, iPad Air, iPad 5th generation, iPad mini 4, iPad mini 3, iPad mini 2
    • iPod touch 6G
  • It does not support iPhone 7 and iPhone 7 Plus  as they aren’t compatible with Luca Todesco’s KPP bypass techniques, just like the Yalu jailbreak.
  • The jailbreak is semi-tethered, similar to LiberiOS jailbreak.
  • Make sure that you take a complete backup of your iPhone, iPad or iPod touch using iTunes.
  • Ensure that your device has enough battery level for the jailbreak process to complete.

••••••••••••••••••••••••••••••••••••‎

   Device Compatibility :


ad728